NEWNC2をNC3に移行したいのですが…

投稿日時: 10/01 NC2移行したい人

NC2のアップデート方法がわからず、移行コマンドを実行できずにいます。

現在使用しているNC2のバージョンは2.4.2.0です。

最新版のNC2をインストールして、その新しいNC2のディレクトリにuploads、templates_c等のディレクトリを差し替えたのですが、移行コマンド実行時に以下のエラーが出てしまいます。(新しいNC2のDB設定を変更し、既存のDBで使用していたものを設定しました。)

Welcome to CakePHP v2.10.22 Console
---------------------------------------------------------------
App : app
Path: /var/www/NetCommons3/app/
---------------------------------------------------------------
2020-10-01 09:24:08 Info: [ValidationErrors] /NetCommons3/nc2_to_nc3/nc2_to_nc3/migration/
2020-10-01 09:24:08 Info: Array
(
[database] => Array
(
[0] => NetCommons2のバージョンが2.4.2.1ではありません。
)

)

このエラーを見る限り、DBのデータをアップデートする必要があるのでしょうか?もしDBのアップデートが必要なのだとしたら、どのようにして行うのでしょうか?

Re: NC2をNC3に移行したいのですが…

投稿日時: 10/03 jsuzuki

こんにちは。

 

NC3移行ツールは使ったことがないので、はっきりしたことはわからないのですが、コンソールのメッセージを見ると、NC2のバージョンを2.4.2.1にしないといけないのではないでしょうか

 

ご自分で、NC2のバージョンが2.4.2.0とおっしゃっていますし、エラーの方には2.4.2.1ではありませんとありますから。

 

お役に立てばと思います。

 

NC2のアップデート方法がわからず、移行コマンドを実行できずにいます。

現在使用しているNC2のバージョンは2.4.2.0です。

最新版のNC2をインストールして、その新しいNC2のディレクトリにuploads、templates_c等のディレクトリを差し替えたのですが、移行コマンド実行時に以下のエラーが出てしまいます。(新しいNC2のDB設定を変更し、既存のDBで使用していたものを設定しました。)

Welcome to CakePHP v2.10.22 Console
---------------------------------------------------------------
App : app
Path: /var/www/NetCommons3/app/
---------------------------------------------------------------
2020-10-01 09:24:08 Info: [ValidationErrors] /NetCommons3/nc2_to_nc3/nc2_to_nc3/migration/
2020-10-01 09:24:08 Info: Array
(
[database] => Array
(
[0] => NetCommons2のバージョンが2.4.2.1ではありません。
)

)

このエラーを見る限り、DBのデータをアップデートする必要があるのでしょうか?もしDBのアップデートが必要なのだとしたら、どのようにして行うのでしょうか?

Re2: NC2をNC3に移行したいのですが…

投稿日時: 10/05 NC2移行したい人

あの後色々検証した結果、無事にDBのアップデートは完了しました。ありがとうございます。

こんにちは。

 

NC3移行ツールは使ったことがないので、はっきりしたことはわからないのですが、コンソールのメッセージを見ると、NC2のバージョンを2.4.2.1にしないといけないのではないでしょうか

 

ご自分で、NC2のバージョンが2.4.2.0とおっしゃっていますし、エラーの方には2.4.2.1ではありませんとありますから。

 

お役に立てばと思います。

 

NC2のアップデート方法がわからず、移行コマンドを実行できずにいます。

現在使用しているNC2のバージョンは2.4.2.0です。

最新版のNC2をインストールして、その新しいNC2のディレクトリにuploads、templates_c等のディレクトリを差し替えたのですが、移行コマンド実行時に以下のエラーが出てしまいます。(新しいNC2のDB設定を変更し、既存のDBで使用していたものを設定しました。)

Welcome to CakePHP v2.10.22 Console
---------------------------------------------------------------
App : app
Path: /var/www/NetCommons3/app/
---------------------------------------------------------------
2020-10-01 09:24:08 Info: [ValidationErrors] /NetCommons3/nc2_to_nc3/nc2_to_nc3/migration/
2020-10-01 09:24:08 Info: Array
(
[database] => Array
(
[0] => NetCommons2のバージョンが2.4.2.1ではありません。
)

)

このエラーを見る限り、DBのデータをアップデートする必要があるのでしょうか?もしDBのアップデートが必要なのだとしたら、どのようにして行うのでしょうか?