NetCommons3.2.0にアップデートするとエラーになりページが見れなくなる

投稿日時: 10/05 ホリデー!!

Apache2.4 CentOS7.1 PHP7.1  MariaDB10.2 のサーバーでインストールしています。

現在のNetCommons3のバージョンが3.1.9です。
バージョンを3.2.0にアップデートしたところ下記に添付した .txtファイルのエラーが表示されサイトの閲覧が不能になりました。
アップデートですが管理画面の「プラグイン管理」、「一括アップデート」と
コマンドラインから2パターンで試みたのですがどちらも同じエラーが表示されました。
3.2.0エラー.txt

この表示されているエラーが出た場合の対処方法を教えていただきたいです。

Re: NetCommons3.2.0にアップデートするとエラーになりページが見れなくなる

投稿日時: 10/10 jsuzuki

外野からすみません。

エラーを見ると、 Permission deniedとあるので、権限、アクセス権の問題だと思われますが、どうでしょう?

自分の例で言うと、zipファイルをサーバにあげ、rootなどで解凍などするとそのユーザの所有権になってしまうので、アクセス権とあわせて再設定しています。

具体的には、

chmod -R 777 /path/to/NetCommons3/

chown -R apache:apache /path/to/NetCommons3/

です。はすしてたらごめんなさい。確認はls -laで。

 

Apache2.4 CentOS7.1 PHP7.1  MariaDB10.2 のサーバーでインストールしています。

現在のNetCommons3のバージョンが3.1.9です。
バージョンを3.2.0にアップデートしたところ下記に添付した .txtファイルのエラーが表示されサイトの閲覧が不能になりました。
アップデートですが管理画面の「プラグイン管理」、「一括アップデート」と
コマンドラインから2パターンで試みたのですがどちらも同じエラーが表示されました。
3.2.0エラー.txt

この表示されているエラーが出た場合の対処方法を教えていただきたいです。

Re2: NetCommons3.2.0にアップデートするとエラーになりページが見れなくなる

投稿日時: 10/13 ホリデー!!

jsuzuki さん

 返信ありがとうございます。
 サーバーにファイルをアップ後に権限、アクセス権のコマンドを入力しアップデートしたところ
 問題なくアップデートが完了しました。助かりました。
 rootで解凍などすると権限等を再設定しないといけないんですね。

外野からすみません。

エラーを見ると、 Permission deniedとあるので、権限、アクセス権の問題だと思われますが、どうでしょう?

自分の例で言うと、zipファイルをサーバにあげ、rootなどで解凍などするとそのユーザの所有権になってしまうので、アクセス権とあわせて再設定しています。

具体的には、

chmod -R 777 /path/to/NetCommons3/

chown -R apache:apache /path/to/NetCommons3/

です。はすしてたらごめんなさい。確認はls -laで。

 

Apache2.4 CentOS7.1 PHP7.1  MariaDB10.2 のサーバーでインストールしています。

現在のNetCommons3のバージョンが3.1.9です。
バージョンを3.2.0にアップデートしたところ下記に添付した .txtファイルのエラーが表示されサイトの閲覧が不能になりました。
アップデートですが管理画面の「プラグイン管理」、「一括アップデート」と
コマンドラインから2パターンで試みたのですがどちらも同じエラーが表示されました。
3.2.0エラー.txt

この表示されているエラーが出た場合の対処方法を教えていただきたいです。

Re3: NetCommons3.2.0にアップデートするとエラーになりページが見れなくなる

投稿日時: 10/15 jsuzuki

ホリデー!!様

うまくいってよかったです。

僕も最初の頃はなんでアップデートすると見えなくなるのだろうと、旧NetCommonsの掲示板で教えていただいていました。

とりあえず、chown chmodをすることを覚えた次第です。

#アドバイスができてよかった。

 

jsuzuki さん

 返信ありがとうございます。
 サーバーにファイルをアップ後に権限、アクセス権のコマンドを入力しアップデートしたところ
 問題なくアップデートが完了しました。助かりました。
 rootで解凍などすると権限等を再設定しないといけないんですね。

外野からすみません。

エラーを見ると、 Permission deniedとあるので、権限、アクセス権の問題だと思われますが、どうでしょう?

自分の例で言うと、zipファイルをサーバにあげ、rootなどで解凍などするとそのユーザの所有権になってしまうので、アクセス権とあわせて再設定しています。

具体的には、

chmod -R 777 /path/to/NetCommons3/

chown -R apache:apache /path/to/NetCommons3/

です。はすしてたらごめんなさい。確認はls -laで。

 

Apache2.4 CentOS7.1 PHP7.1  MariaDB10.2 のサーバーでインストールしています。

現在のNetCommons3のバージョンが3.1.9です。
バージョンを3.2.0にアップデートしたところ下記に添付した .txtファイルのエラーが表示されサイトの閲覧が不能になりました。
アップデートですが管理画面の「プラグイン管理」、「一括アップデート」と
コマンドラインから2パターンで試みたのですがどちらも同じエラーが表示されました。
3.2.0エラー.txt

この表示されているエラーが出た場合の対処方法を教えていただきたいです。